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1 Introduction

1.1 Maple Flow

Maple Flow is a new calculation tool from Maplesoft. Maple Flow offers a freeform user interface combined with a
comprehensive math engine. Use Maple Flow for engineering, scientific, and technical calculations and documentation.

Maple Flow gives you

» A spatially aware mathematical canvas that replicates the design metaphor of a physical whiteboard
» Automatic recalculation to ensure that results are always up to date

* A broad, rich mathematical language with many functions

* Visually impactful, fully programmatic plots

* A coding region with full access to the Maple programming language

Note for non-Windows users: The keystrokes given in this document are for Windows. If you are using a different
platform, see the keyboard shortcuts for your platform in Keyboard Shortcuts (page 32).

1.2 What Does This Manual Aim to Do?

This manual describes
* The Maple Flow interface

« Differences with the Maple user interface and programming language that an existing Maple user may experience.

This manual should be read in unison with the in-product tutorials and exercises; these are available from the Tutorial
link on the Maple Flow Home page. If you've closed the Home page, you can access it again from the View menu:

¢ Select View > Home
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Tutorial

Technical Applications

v ea— Learn how to navigate around the

Navigating around the canvas canvas, create math and text containers,
and move them into position

Solve equations numerically and symbolically

Import and export data

Fit a curve to data

|  Entering math Learn how to enter and edit math iunal Procesn
Thermophysical Data
I Opti it
Evaluating math Learn how to evaluate math and get Optimization
. results
— Evaluation order and automatic Learn how Maple Flow's spatially aware
recalculation evaluation model works

M Discover the basic math concepts

Basic Math Concepts needed to be a succesful Maple Flow
user

M Maple Flow contains a rich collection of
Built-in functions mathematical functions for science,
engineering and technical analysis

M1 Maple Flow has many data structures
Data structures for different types of analyses

- Learn how to keep your analyses
Units dimensionally censistent and eliminate
| unit conversion errors

Plotting Create visually impressive, flexible plots

Figure 1.1: Overview of in-product tutorials

This manual does not describe the math functionality of the Maple Flow in detail, but makes references to specific
functions in context of a broader discussion. The detailed documentation for the math functionality resides in the Maple

online help: http://www.maplesoft.com/support/help.

1.3 What Is the Relationship between Maple and Maple Flow?

First, some definitions:
* Maple refers to the (i) Maple programming language and (ii) Maple interface.

* Maple Flow refers to the new product whose manual you are reading.

Maple Flow
* Is built on top of the Maple programming language

* Borrows a few elements from the Maple interface

Maple Flow's "language" is the commands (and their syntax), data structures and programming language. These are
based on the Maple programming language; you can use any of the math functions in Maple in your Maple Flow analyses.

Maple is installed automatically when you install Maple Flow.


http://www.maplesoft.com/support/help
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1.4 If You're a Maple User

If you already use Maple, you'll appreciate the unique twist that Maple Flow offers with its spatial evaluation model
and automatic calculation updates. You'll also get a head start because you'll be familiar with Maple's programming
language, functions, and features.

Maple Flow differs from the Maple interface and programming language in a number of ways. Several important dif-
ferences are listed in Table 1.1.

Table 1.1: How Maple Flow differs from Maple

Maple Flow

You enter math and text at any point, simply by clicking with
your mouse, and typing.

Maple

You can enter commands at execution prompts, which are
largely aligned to the left (except when inserted into
multicolumn tables), and linearly progress down the
worksheet.

This is in much the same way that you can write math at any
point on a whiteboard.

The evaluation model is forward in space. Any assignments
are only valid at any point to the right or below where they
are made.

The evaluation model is forward in time. You can use
assignments above or below where they are made, at any time
after the assignment is made.

Most users progress linearly down a worksheet, but the
apparently linear form of a worksheet is not always reflected
in the displayed results.

Multiplication needs to be explicitly stated.

Multiplication can be implicit (i.e. entered with a space) or
explicit.

More numeric evaluation by default (for example 5/10
evaluates to 0.5)

Results are kept symbolic except when requested to be numeric
(for example, with the evalf command).

Units are automatically combined. That is, N/m? is
automatically reconciled to Pa.

Units are only reconciled if explicitly requested by the user
(for example, by loading a Units package).

Maple Flow canvases are always up to date and reflect the
current state of all assignments. Any changes or additions to
the canvas automatically cascade down the canvas. Automatic
recalculation can, however, be disabled.

Individual commands, groups of commands, or entire
worksheets are only updated if requested by the user. This
means results may not reflect the current value of definitions.

Matrix, vector, and array indices are only entered with square
brackets.

Matrix, vector, and array indices can be entered with square
brackets or typeset subscripts (in 2-D input).

Math is entered into the canvas in mathematical notation, but
programmatic content is entered in Maple notation.

Equations and programs can be entered in typeset mathematics
notation (often called "2-D math") or Maple notation ("1-D

math").

Maple worksheets cannot be loaded into the Maple Flow, or vice versa.

1.5 Maple Flow Help System

The in-product help system, accessed through the Help menu, provides information on many key commands in Maple
Flow. Each help page gives details on the usage of a command, including the calling sequence, parameters, options,
and examples.

Search: Search for a command name, keyword, or phrase.
Browse: Browse the table of contents to view a structured list of help topics

View Help Page as Worksheet: You can open any help page as a worksheet to interact with the page and modify the
examples.

» With the help page displayed in the right pane of the help system, from the View menu, select Open Page as
Worksheet. A new worksheet window opens.
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?
 Alternately, click Open current page as worksheet () in the help system toolbar.
Additional Documentation

Since Maple Flow uses the Maple programming language, you have the ability to use the vast math functionality that
is part of the Maple programming language. When browsing the help system, some hyperlinks take you to additional
detailed documentation for the math functionality that reside on the Maplesoft website, in the Maple online help:

http://www.maplesoft.com/support/help. Note that these pages are formatted as Maple pages, not Maple Flow pages,
so the examples will look a little different.

1.6 Interface

The different parts of the Maple Flow interface, as seen in Figure 1.2, are:

» Canvas — the workspace

* Main toolbar — This toolbar is always at the top of the Maple Flow window.

» Context toolbar — This toolbar, located directly above the canvas, is relevant to the current selection.
 Palettes — In the left pane, these provide an easy way to enter a math expression, matrix, Greek letter, or units.

» Context panel — Some options relevant to the current selection appear here, such as numeric formatting and units
formatting.

» Status Bar — Displays system information

%
File Edit View Inset Format Help
DBEE x98 s B o,AQQ A I o
Palettes 4 [ureric] Byroic] [ C 20 vt v | [ -z~ BIU B== Lg == »
P Expression ~ [P a3 "
:E% Sole Equations Numerically and Symbolically
ni
et Main Toolbar Context
Context Toolbar Panel
You can solve equations numerically with fsolve
Palettes Equation system |equailuns — {x+ log(x) =3, + y=x} | vars == {x,y}
Canvas
Numerical solution res — fsolve(equations, vars) = {x=2.208,y = —2.667}
Check the correctness of the solution eval(equations, res) = {2.208 =2.208, 3.000=3)

Assign the results to names
X = eval(x, res) = 2.208 y = eval(y, res) = —2.667

X + log(x) = 3.000
Status Bar

You can solve and rearrange equations symbolically with solve

@ Ready

Memary: - Time: - Zoom: 100%

Figure 1.2: The Maple Flow interface

Customizing the Interface
Customize your Maple Flow preferences using the Options Dialog.
To open the Options Dialog:

 From the toolbar, click the Options icon (£X).


http://www.maplesoft.com/support/help
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Under the Interface tab, you can specify the following:
* Open worksheets in new tab or new window.
* Open hyperlinks in new tab or new window.

e Default zoom.

Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the setting
to the current session an future sessions.

Options d

Interface
Open worksheets in: | Mew Tab e
Open hyperlinks in: | Mew Tab e

Default zoom: i1

Apply to Session Apply Globally Cancel

Figure 1.3: Options dialog




2 Canvas
2.1 Grid

When you drag math and text containers, the positions of containers are snapped to a grid. By default, the grid is not
displayed.

To display the grid, click the Enable/Disable Grid button on the main toolbar.

NEE $68E a2 B & QaQQ 0 g8

Figure 2.1: Enable/Disable Grid button on toolbar

2.2 Grid Cursor

The grid cursor is illustrated in Figure 2.2 and by default appears in the top left corner of every new canvas.

_I_

Figure 2.2: Grid cursor

The grid cursor can be moved by pointing and clicking with the mouse, or with the arrow keys.

Math and text containers are created at the location of the grid cursor.

2.3 Math and Text Containers

On the canvas, you can create math boxes or text boxes. Each box can be moved; the position of a math container de-
termines the order in which it is evaluated (as illustrated in Figure 3.8).

A container can be in one of three states, as described in Table 2.1.

Table 2.1: Container states

Math Text

Stationary with no focus. A math container| 5

O e x2=9 Squaring a number
in this mode is still "live", and the Maple
Flow will update its result if an upstream
parameter changes.
Editing Numeric: ISquaring = numb er—l
* Only one container can be in editing >

mode at any one time. x“=9
* A math container has a solid dark green

border if numeric, or a dashed light green

border if symbolicj' (see Numeric and Symbolic:

Symbolic Evaluation Modes (page 9))
* A text container has a blue border. |r_;(-2-:-g- -I

1

* You will see a flashing cursor, whose
position can be changed with the arrow
keys or mouse.

Move J .
¥ =9 Ebuuarlnc% numbeﬁ

* Math and text containers have a light
blue border in move mode.




7  Canvas

Math Text

¢ One or several containers can be in move
mode.

¢ Move the containers with the mouse or
Ctrl + arrow keys.

2.4 Moving Containers

Single Container

With the mouse

To move a container with the mouse:
1. Move the mouse pointer over a container.
2. Move the container to another position by click and dragging.

3. Release the mouse button when the container is in the desired position.

With the keyboard arrows

To move a container with the keyboard:
1. Move the grid cursor into a container so you see a green border. The container is now in editing mode
2. Do one of the following:

» Press Ctrl and use the arrow keys to move the container one grid space at a time.

* Press Ctrl + Shift and use the arrow keys to move the container a single pixel at a time.

Group of Containers

To move multiple containers:

1. Click in a blank part of the canvas.

2. Drag a selection box around a group of containers.

3. Release the mouse button.

4. Move the mouse pointer over one of the selected containers.
5

. Drag the containers to another location.

Bringing Containers from Back to Front, and Vice Versa

You can potentially have two containers at the same grid position.You can bring the lower container forward, or send
the top container back, by using Flip to Front and Flip to Back buttons.
o

NEE *E5E G~ B & QAQ

Figure 2.3: Flip to Front and Flip to Back buttons

2.5 Editing an Existing Container

To enter editing mode on an existing container, do one of the following:
« With the mouse, click the container.

» With the arrow keys, move the grid cursor onto the container.
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2.6 Inserting or Removing White Space

You can insert or remove space in the canvas (i.e. grid rows) by using the Enter, Backspace, and Delete keys.

Adding Blank Rows

To add blank rows, place the grid cursor on a blank part of the canvas and press Enter. This shifts all content on and
below the same row as the grid cursor down.

Deleting Blank Rows

To delete blank rows, click on a blank row of the canvas and press one of the following:
» Backspace to remove that blank row and shift the grid cursor and all content below the grid cursor up

* Delete to remove that blank row, and shift all content below that row up.



3 Entering Math
3.1 Creating a Math Container

A math container is a box in which you enter math that is to be evaluated.

To create a math container:
1. Click on a blank part of the canvas.

2. Begin typing your math. As soon as you enter the first character, a math container is created automatically.

3.2 Deleting a Math Container

Drag-select the math container and press Delete.

3.3 Evaluating Math and Displaying Output

All math is evaluated in the canvas, using a left-to-right, top-to-bottom order (see Evaluation Order (page 13)). When
you need to display results, evaluate and display output.

To evaluate math and display output:
1. Enter the expression, then with the cursor at the right end of the expression, press = .

2. Press Enter or the arrow keys. The result is displayed. After evaluation, the focus leaves the math container.

3.4 Numeric and Symbolic Evaluation Modes
Maple Flow offers two math evaluation modes—numeric and symbolic.

Table 3.1: Difference between numeric and symbolic evaluation modes

Numeric evaluation mode Symbolic evaluation mode
‘ (C 2D Output v | [l v/ [12 v] B T | [Numeric| [Symbolici | C 2D Output V‘ Arial YI[12~] BT

% + 2.exp(3) + Pi + sin(4) = 42.889 !
1

The numeric evaluation mode performs as much numeric evaluation as possible. For example:

» Rational fractions (such as %) are converted to floating-point numbers

* Piand exp(1) evaluate to floating-point numbers

Symbolic evaluation mode prevents numeric evaluation (except when requested by the user). For example:

» Rational fractions are only converted to floating-point numbers if request by the user (e.g. with the evalf command)

 Pi evaluates to a symbolic name

In both modes, unassigned names are evaluated symbolically (i.e. in numeric mode, unassigned names do not give an
error when evaluated).

The current mode of an existing math container is given by clicking inside it, and observing the state of the border or
Numeric/Symbolic buttons in the Context toolbar, as illustrated in Table 3.1.

By default, new math containers are numeric. Clicking the Symbolic button in the Context toolbar switches the in-focus
math container to symbolic mode. Alternatively, use the shortcut key Alt + S.
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Holding down the Symbolic button for a second makes symbolic evaluation mode "sticky". This is indicated with a

padlock by the Symbolic button (). This means that all future math containers will be symbolic (until symbolic
mode is toggled off with another long click on the Symbolic button).

3.5 Numeric Formatting

By default, Maple Flow displays numeric results with three decimal places. To customize the numeric formatting:
1. Place the editing cursor on a numeric result.

2. Use the Number Format options in the Context Panel.

~

1.41 x 10°

MNumber Format:

Scientific v

_ 2
1002 = 1.41 < 10 2 Decdmal places
1 Minimurn Exponent Digits

|:| Show + on positive exponents

Figure 3.1: Numeric formatting

3.6 Creating a Definition
You can assign a numerical value or an expression to a name by using := (a colon, followed by an equal sign).

For example, entering a:=4 in a math container assigns the value 4 to the name a.

3.7 Basic Arithmetic

Equations are entered in typeset math notation, using standard keys such as /, *, + and -.
Note that multiplication must always be explicitly stated. For example, you must enter 3*x, not 3x.

You can also use the Expression palette or Command Completion feature to enter typeset math, as illustrated in Table
3.2.

Table 3.2: Using the Command Completion feature and Expression Palette to insert a square root

sgrt .
W Expression
a b
— a Ja
Sqrt sifrt b
q % d
£ > nJ-? lal _Insert uare root J H
{E] a, fi=a-y
-X x<a
fi=(a,b)=z f(x)
T X X>a
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|(a) Command completion |(b) Expression palette |

For more information on command completion, see Command Completion (page 28).

3.8 Complex Numbers

Imaginary numbers are entered with a number followed by the suffix i, with no multiplication between the two. For
example, 2+2i.

The unit complex number is created with 1i. You cannot just enter i for the unit complex number.

To create a symbolic multiplier on an imaginary number, you need to enter x*1i.

3.9 Units

Entering Units

You can enter units in several different ways.

Units Palette

You can enter units using the Units palette located in the Palettes pane on the left side of the Canvas. Click the desired
unit (using the Dimensionality drop-down list to switch to different groups of units), or insert the unit placeholder (as
illustrated in Figure 3.2) and overwrite the placeholder.

You may want to place a space between the number and the unit.

Dimensionality:
length v
A it
in m
x=234 | e = [k=aqmm | ™ [x=34 | @ x=34m?
yd km
cm  mm
nm
unit

Figure 3.2: Inserting a Unit with the Units Palette

Unit function

You can use the Unit() function to assign a unit.
x = 3.4 -Unit(m?)
Figure 3.3: Using the Unit() function to assign a unit

Keyboard shortcut

Press Ctrl + Shift + U to enter a unit placeholder. Then, replace the placeholder with the desired units.

x = 3.4 [

Figure 3.4: Using keyboard shortcuts to insert a unit placeholder
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Editing Existing Units

Move the cursor onto the unit. When the unit has focus, it is highlighted by a light blue box. You can now change the
unit.

Deleting all the characters in a unit placeholder will leave an empty placeholder one character in size. Deleting this
empty placeholder will remove the unit placeholder entirely.

When the results of your calculations contains units, you can use the units formatting options in the Context Panel to
rescale the units to units you'd prefer to see.

~ 13235.294 Pa

Convert Qutput Units:
(®) Mo Conversion

(") Choose System | 5I w
force == 45N
(") Enter Unit
area == 3.4 cm” (") Choose Unit am
anémm'r_
force _
stress i = ——— = 13235.294 Pa Mumber Format: | &M __
darea
auéﬂullll.
Mone ba
Pa
pz

Figure 3.5: Convert output units

3.10 Notes about Math Input

Numerical Evaluation and Accuracy

Any purely numerical operations are evaluated to a floating-point approximation.

= 0.500

P =

J2 = 1.414
sin(y3 x) = sin(1.732-x)
Figure 3.6: Numerical operations

The Digits environment variable controls the number of digits that Maple uses when making calculations with software
floating-point numbers.
The default value of Digits is 10. The value of Digits is changed with the assignment operator (e.g. Digits:=15).

Figure 3.7 illustrates the effect of changing digits from its default value of 10 to 15 on the evaluation of 205, (Note

that numeric formatting on the result of 29-5 has been set to Fixed with 20 decimal places.)
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Digits == 10
2%%= 1 41421356200000000000
Digits := 156

2%%= 1 41421356237310000000

Figure 3.7: The effect of Digits on numerical accuracy

Evaluation Order

Maple Flow evaluates calculations from left-to-right, top-to-bottom (much like reading a page from a book). This
means that downstream calculations only "see" assignments on the left or above. This is illustrated in Figure 3.8.

L.

Figure 3.8: Spatial evaluation

3 2=

You can change the evaluation order by moving math containers around.

Nonexecutable Math and Disabling Evaluation

You may want to enter nonexecuting math for documentation purposes. You can do this by entering math into a text
container. For details, see Entering Math in a Text Container (page 14).

If you want to author content without any math evaluating in the Maple Flow worksheet, but eventually the math will
be executed, you can temporarily disable evaluation.

To disable evaluation:
. . = o . o .
¢ Click Turn evaluation off (g3 |@) on the toolbar. An indicator will appear at the top of the canvas indicating Evaluation
Disabled.

To enable evaluation:

* Click the icon again.
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4.1 Entering Text

To enter text:

1. Click in a blank part of the canvas.

2. Press Space to create an empty text container. This will have a blue border.
3. Type your text.

4. Use the context toolbar to format your text.

[ dz~ BIU B== Lg =i

My first tex{

Figure 4.1: Entering and formatting text

Entering Math in a Text Container
You may want to enter nonexecuting math for documentation. You can do this by entering math into a text container.

To enter math in a text container:
1. Anywhere inside a text container, press Ctrl + R to switch into math mode.
2. Enter your math.

3. If required, press Ctrl + T to return to text mode.

4.2 Math and Text Styling

Formatting the Content of Single Containers
To change font, size, and font color, drag-select the content and use the context bar.
Applying Background Color to a Math Container

Math containers can also have a background color. This can be useful, for instance, to highlight a math container that
contains the assignments for the variables that are used in the later calculations.

To apply a background color, right click on a math container.

a=1[
Cut
b= 2 Copy
Paste

Background ColorI}

Figure 4.2: Apply background color to a math container

The color selector dialog appears. Select a color.

14
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Select a Color *

[235,204,153]

| Nane

@

OK Cancel

Figure 4.3: Select background color

To apply a background color,

Figure 4.4 shows the result of using background color on the math containers that define two assignments.

fi=x—=a-sin(bx)

plot(f, 0_.4) =
1.5

0.5

Figure 4.4: A math container with background color
Applying and Changing Styles

The style drop-down list contains several formatting styles for text and math.
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[urveric] [Eymboif®] C Text v | [ypia -] BIU B== Lg =i=
R ——

I his iste)d

Figure 4.5: The Styles drop-down list

By default:

+ Text is given the Text style.

» Math input is given the 2D Math style.

* Math output is given the 2D Output style.

You can apply other styles with the other entries (such as the Title style for text). You will need to drag-select the
content of the container and pick the appropriate style.

Use the Format > Styles menu to change the typeface of the pre-defined styles.

Use the Format > Manage Style Sets menu to:
» Export and save the active style set.

* Load and apply an existing style set.

4.3 Using Sections
You can use sections to organize your document.

To create a section:

1. Select Insert > Section.
If you select some content and then use Insert > Section, the selection will be enclosed in the section.

2. Enter a title for the section. You can modify the font/style for the title.

To change the size of the section, you can drag the bottom boundary line. If you drag the section boundary past addi-
tional content, the section now encloses that content.

To collapse a section:

* Click the collapse button ((=)).
To expand a section:

* Click the expand button ((4)).

Figure 4.6 shows an example of a Maple Flow worksheet with sections. The first section is collapsed and the second
section is expanded.
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Parameters
_+_

Area Calculation

Area == d-w-h = 98304 cm”’

Figure 4.6: Sections in a worksheet
Evaluation order still applies as it normally does, and content in a section is evaluated even if a section is collapsed.

Controlling the Display of Sections
You can edit a section title by clicking in the text box for the title, or by clicking on the top boundary line.
Tip: If a section does not have a title, click on the top boundary line. This opens the title text box for editing.

You can control the display of sections using Format > Section Style. From this dialog, you can
» Control whether to display the top and bottom boundary lines.

* Specify margins.

* Specify boundary line thickness.

* Specify boundary line color.

* Specify boundary opacity.

» Control whether to display the expand button.

Note that if the section style is set up so the expand/collapse button is not displayed, you can expand or collapse a
section by doing one of the following:

* Click the left most part of the top section boundary line

* Double-click anywhere along the top section boundary line.

For information on controlling the display of sections when printing or exporting to PDF, see Printing a Worksheet
with Sections (page 31).

Removing a Section

To remove a section:

« Use Edit > Remove Section. The content remains in the canvas, and the section boundaries are removed.
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4.4 Hide Commands

When creating a document, you have control over the display of the content of math containers. You can hide the input
expression and just show the resulting output by right-clicking on the math container and selecting Hide commands
from the context menu.

In the case of an assignment, you can select either Hide commands or Hide commands and name.

b:=15
a= % =3
sol == fsolve(logla x) +a=x x1 = 0017
Cut
Copy
Paste Ctrl+V

Hide commands

L5

Hide commands and name

Figure 4.7: Hide commands

There is an option to display a visual indicator for math containers that have hidden commands. To enable this setting,
select View > Visual Indicators. When Visual Indicators is selected, a math container with hidden commands is drawn
with a gray circle at the top left corner.

b:=15

b _
d —?—3
sol= 0.017

Figure 4.8: Marker indicates hidden command

To show the command again, right-click and select Show commands from the context menu.

4.5 Including Images and Drawings
You can insert images into your worksheet using Insert > Image.
You can also use the drawing tools on an image.

Drawing Tools

To view the drawing tools, select an image in your Maple Flow worksheet. The Context toolbar displays the Drawing
toolbar.

©ME-|e -

M |

Figure 4.9: Drawing Toolbar

The tools include the following: selection tool, pencil (free style drawing), eraser, text insert, straight line, rectangle,
rounded rectangle, oval, diamond, alignment tool, drawing outline tool, drawing fill tool, and line style tool.

Tip: For the text, line, rectangle, round rectangle, oval, and diamond tools,
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- Click once on the toolbar icon to insert that type of object into the drawing. The tool is activated. For example,

N

- Click twice on the toolbar icon to insert multiple objects of the same type without having to reselect the tool.

The icon is highlighted yellow. For example, \ . The tool remains activated until you select another toolbar
icon.

Text

You can change the
font or add 2-D math;

1x
e dx

To insert text in the canvas:

1. Click the text icon (i T)).

2. Click in the canvas (or on the image). A text box appears.

3. Enter text and modify font as necessary using the toolbar font and font size drop-down lists. Include math in the
text box in the same way you include math in a text container. See Entering Math in a Text Container (page 14).

4. Optional. Select a fill color for a text box or select the line color for the border in the same way it is done for objects.
Lines - Straight, Resizing, Adding Arrows
Drawing Straight Lines

To draw a straight line:

1. Click the straight line icon (™).

2. (Optional) From the EI menu, select the line style, thickness, and arrow points:




20 + Creating a Polished Document

3. In the canvas, click and drag the mouse. A straight line is drawn.
4. To complete the line, click the mouse twice or press Enter. The drawing feature switches to the Selection tool.

5. You can draw more than one connected line; to complete your drawing, click the mouse twice, press Enter, or bring
the end of the last line back to the start of the first line.

6. To remove the last point drawn, press Esc.

Drawing a Line that Snaps to Vertical, Horizontal, or a 45 Degree Angle

To draw a line that snaps to an orientation that is a multiple of 45 degrees:
1. Click the straight line icon.

2. In the canvas, click and drag the mouse.

3. Press and hold the Shift key to snap to a 45 degree increment.

4. To complete the line, click the mouse twice or press Enter.

Drawing a Line that is Attached to a Shape
To draw a line that is attached to a shape in the canvas:

If you have inserted a shape in the canvas, you can draw a line that is automatically attached to that shape.
1. Click the straight line icon.

2. Press and hold the Ctrl key, and, in the canvas, hover your mouse cursor over the existing shape to which you want
to attach the line. The shape is highlighted in green.

3. To draw the line, click and drag the mouse.

4. To complete the line, click the mouse twice or press Enter. The drawing feature switches to the Selection tool.
Resizing Lines

To resize objects drawn with straight lines:

1. Select the line to be resized using the selection tool.

2. With the mouse pointer over a grab box, click and drag the line to increase or decrease its size.

3. Release the mouse button.

Changing Vertices of Lines
To change vertices of drawn lines in the canvas:

When an object is selected, grab boxes and nodes at the vertices are displayed.
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1. Click a node and drag the mouse to the desired point, thereby changing the vertex position.

2. Release the mouse.

Changing the Line Style

To change the style of drawn lines:

You can change the line style, thickness, and arrow points of a line either when it is drawn or afterwards.
1. Select a line using the selection tool.

2. From the El menu, select a line style, thickness, or arrow direction and shape.

=
&
=
g

ShLE

The selected change is automatically applied to the straight line.

For example, a straight, thick line will have a solid arrow on the right end after clicking on the menu item displayed
above.

—»
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Color Selection Dialog

The drawing outline tool, drawing fill tool, and canvas properties tool allow you to select colors for shapes, lines, and
the canvas grid lines. Choose a color by using one of the following tools in the color selection dialog:

Color Palette

@ -l -] — -]

o P
o = /¢

To select a color, click a color from a palette of pre-defined colors.

The last five colors that you select are displayed in the box below the color swatches. If you want to view the RGB

values of a particular color, hover your mouse cursor over a color swatch.

Color Wheel

@ -l -]

e

4

To select a color:

1. Move the slider beside the color wheel to display a range of colors.

2. To select a color, click a point in the color wheel.
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Color Value Sliders

@E-le | —-|
L 127 %
184 -+
L 0+

o 3 /

To select a color, specify the RGB values of the color by moving the sliders. Alternatively, you can use the spinners
to scroll to certain values or type the values directly in the fields. For each RGB value, you can specify a number from
0 to 225.

Color Magnifying Glass

To select a color:

1. Select the eye dropper icon (f ).
2. Hover the color magnifying glass over an area on your screen that displays the color you want to select.

3. Using your mouse cursor, in the circle, click a point that displays the color.
To cancel your selection, right-click the circle.
Pencil Tool - Free Form drawing

To draw with the pencil tool in the canvas:

1. From the drawing icons, select the pencil tool icon (f ).

2. Click and drag your mouse in the canvas to draw lines. Release the mouse to complete the drawing.
Selection Tool - How and When to Use
To select items in the canvas use the selection tool (k).

You can use the selection tool to select a single object or a group of objects. To select a group of objects:

Using the selection tool, click and drag the mouse around the items to be grouped. Release the mouse button. The items
are temporarily grouped.

Apply formatting as desired, for example by using the alignment tools in the Drawing toolbar.



24 + Creating a Polished Document

To temporarily switch to the selection tool (when using another tool), press and hold the Tab key (Command, Mac).
You can move and resize objects. When you release the Tab key, the tool will revert to its previous setting. This allows
you to tweak something you just drew.

Filling Objects - Solid or Gradient Fill Colors

Filling an Object with a Solid Color

To fill an object with a solid color:

1. Select the object in the canvas.

2. From the menu, select the solid fill style at the top (next to None).

3. From the same menu, click the left color bar at the bottom, and select a color from the color palette.

% B~ —» -4

None

IR
_ :-‘

Image | Browse...

4. To change the line color, select a color from the menu.
EN RN NN

Filling an Object with a Gradient Color

To fill an object with a gradient color:

1. Select the object in the canvas.

2. From the menu, select one of the gradient fill styles, the square icons.

3. From the same menu, click the left and right color bars at the bottom to select a color from the color palette for each
part of the gradient.
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R

See below for instructions on filling an object with an image.

4.6 Creating Hyperlinks

You can add a hyperlink to a worksheet that links to another Maple Flow worksheet, a webpage, and more.

To insert a hyperlink:

1. In a text container, select Insert>Hyperlink. The Hyperlink Properties dialog opens.

2. For the Link Text field, enter the text to be shown.
3. Select the link type.
4

. For the Target field, enter the destination. Note that you have to save your document if you want to use a relative

path.
5. Optionally, you can add a hyperlink tooltip.

You can also create a hyperlink by selecting some text and using the Format > Convert > Hyperlink menu item.

To edit the hyperlink properties, right-click the hyperlink and select Hyperlink Properties from the context menu.

You can create a hyperlink to a Maple Flow help page. For example, setting Type to Help Topic and Target to solve

creates a link to the solve help page.

% Hyperlink Properties

Link Text: |solve

Image:

[w]
o
o
I}
m

Type: | Help Topic  ~

Figure 4.10: Help Topic Hyperlink

Target: solve| Browse...

In addition to hyperlinks, your worksheet can contain shortcut components, which are clickable image links. The default
look of a shortcut is shown in Figure 4.11, but you can change the image used. The Application Gallery in Maple Flow

uses shortcuts.
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Shartout

Figure 4.11: Shortcut

To insert a shortcut:

1. Click on the canvas.

2. Select Insert > Shortcut. A shortcut component is inserted at the cursor.

3. To edit the shortcut properties, select the shortcut component, and in the Context Panel the shortcut properties are

available.

Shartout
Mame:

Shortcutd

Tooltip:

Caption:
Shortcut

Link Target:
Maple Flow Worksheet File

Image: (none)
Scale to a specific size

Width: 84

Height: 64

Enabled

Visible
[] Use Specified Text Width: |10

>

Change...

Figure 4.12: Shortcut Properties

4. Specify a caption, which appears below the image. Optionally, add a tooltip.

Note: The Name field is used by Maple Flow to identify the component. The caption is what is visible.

5. Specify a link target. You can link to a Maple Flow worksheet or URL. You can also use the Shortcut to open a
blank Maple Flow worksheet,

6. If desired, change the image.



5 Further Tools: Mathematical Functions, Programming,
and Plots

5.1 Mathematical Functions

Maple Functions
Maple Flow is built on top of the Maple programming language. You can use most Maple functions in Maple Flow.

Maple package functions are used in the long form. For example, SignalProcessing:-FFT(). Note: Use of the with()
command to load packages is not supported.

The Maple programming language is described in the Maple online help: http://www.maplesoft.com/support/help.

Unsupported Maple Keywords, Commands, and Packages

As noted above, the with() command is not supported, and instead package commands should be called using the long
form of their name. In addition, some Maple keywords, commands, and packages are not supported. The following
are some examples, but not a complete list.

The assume command is not supported (use assuming instead). Some keywords, such as read and save are not supported.

These Maple packages are not supported:
 Physics

» Tolerances

* DocumentTools

» Typesetting

5.2 Plots

You can create a plot with the Maple language plot command. A simple example is given in Figure 5.1.

plot(sin(x), x=0.10) =
1

Figure 5.1: A simple plot using a Maple plot command

27
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5.3 Command Completion

Maple Flow offers a dialog for command completion. Maple Flow suggests commands and parameters that complete
what you have already entered.

The command completion dialog is initiated by pressing Ese or Ctrl + Space.

fscr s
fsolve feolve
fsolve fsolve(eqn)
fsolve (equation set) fsolve( {ean1, ean2, ...})
fsolve (equation set, complex solutions) fsolvei eant. eanz. .} 'complex)
€ >

Figure 5.2: Command completion window

5.4 Code Editor

The Code Editor lets you write Maple procedures to use in a Maple Flow canvas. To learn how to write a Maple pro-
cedure, read the online Maple Programming Guide:
https://www.maplesoft.com/support/help/Maple/view.aspx?path=ProgrammingGuide/Contents

To view the code editor, click the Code Editor button on the main toolbar, as illustrated in Figure 5.3. Alternatively,
from the Edit menu, select Code.

O “HE A BEP|aQ O 58

Figure 5.3: Code Editor button on main toolbar

Note: You can only enter proc definitions in the code editor. That is, your code should be in the form:

FirstProc:=proc(...) ... end proc;

NextProc:=proc(...) ... end proc;

To define the procedure, enclose a sequence of statements between proc(...) and end proc statements, and specify the
parameter name(s) in the parentheses after the proc statement. For example, a simple definition for a procedure that
takes one parameter and returns the square of the parameter is:

MyProc:=proc (x) x"2; end proc;


https://www.maplesoft.com/support/help/Maple/view.aspx?path=ProgrammingGuide/Contents

6 Printing and Exporting to PDF
6.1 Print Extents

Selecting View > Print Extents displays dashed horizontal and vertical lines. These indicate the extents of a printable
page, taking into account the chosen page size, margins and headers/footers. Pages are printing column-by-column.

DB 2 B P A’ D 38

<
Palettes N «
W Expression

|
W Matrix
Rove: e
Columns:
Type:| Custo... ~
Shape:[Any  ~
LAy  ~
£ Insert Matrix

Pat

» Greek
P Units

* Ready C:\Program Files\Maple 2021\toolbox\MapleFlow Memory: 20.18M Time: 0.23s Zoom: 100%

Figure 6.1: Print extents

The on-screen positioning and size of math, text, plots and images will be reflected in the printed page or exported
PDF.

6.2 Headers/Footers

The Insert > Header Footer menu lets you specify a header and/or footer. This will be seen in the printed page or
exported PDF, but not in the working environment.

29
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Predefined Header and Footer Custom Header Custom Footer

Header: None v Footer: None ~

Print Print Previ... [] Apply Globally Cancel

Figure 6.2: Inserting Headers and Footers

6.3 Page Setup and Print Preview

The File > Page Setup menu lets you change the page size, orientation, and margins, for printing.

a1 Pa
Paper
Size: Letter w
Source: Automatically Select w
Crientation Margins (inches)
(®) Portrait Left: 0.75 Right: [0.7%
() Landscape Top: 0.75 Bottom: |0.75

OK Cancel
Figure 6.3: Page Setup

The File > Print Preview menu lets you preview the printed page or exported PDF.
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6.4 Export to PDF

To export the canvas to a PDF, click Print > Export.

6.5 Printing a Worksheet with Sections
Whether printing or exporting to PDF, if your Maple Flow worksheet has sections, you can select how it is printed.

When you select Print or Print Preview, the Section Options for Print and PDF dialog opens. Select one of the following:
* Print/export document with all sections expanded.

* Print/export document keeping sections exactly as shown on-screen.
If you selected the first option, in addition, specify whether to print the section boundary markers.

For more information on controlling the display of sections, see Controlling the Display of Sections (page 17).



7 Keyboard Shortcuts

Table 7.1: Keyboard shortcuts

| Windows

Linux

Mac

Canvas operations

With the grid cursor on an
empty row: move the grid cursor
and all content below the grid
cursor, down

Enter

Enter

Return

With the grid cursor on an
empty row: moves the grid
cursor and all content below the
grid cursor, up

Backspace

Backspace

Backspace

With the grid cursor on an
empty row: move all content
below the grid cursor up

Delete

Delete

Delete

With the grid cursor on a
container: move the container

Ctrl + arrow keys
Ctrl + Shift + arrow keys

Ctrl + arrow keys
Ctrl + Shift + arrow keys

Command + arrow keys
Command + Shift + arrow keys

Math

Add units to a value or Ctrl + Shift+ U Alt + Shift + U Command + Shift + U
expression
Navigate through expression | [« ][—][1][}] [<I=101] (<1101
Move cursor to different level |[—] [—1] [—]
in expression, e.g. out of
exponent
x/ x/ x/
Fraction X Y Y Y
Inline fraction x/y xVy xVy xVy
Literal subscript X X__n (two underscores) X n X_n
n
A 7aS A
Exponent x" xn xn xn
Command or symbol Esc, or Esc, or Esc, or
completion ) )
Ctrl + Space Ctrl + Shift + Space Command + Shift + Space
Toggle between Alt+S Alt+S Ctrl + S
numeric/symbolic mode for
math container
Text
Create a text box Space Space Space
Switch to math entry in a text |Ctrl + R Ctrl + R Command + R
box
Switch back to text entry Ctrl+ T Ctrl+ T Command + T
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Index

Symbols
=10
=9

A

accuracy, 12

assigning
hide commands and name, 18
value to a name, 10

B

background color

for math container, 14
bring

to front/back, 7

C

canvas, 4
code editor, 28
command completion, 28
commands
getting help on, 3
complex numbers, 11
context panel, 4, 10
control display of math
hide commands, 18
numeric formatting of result, 10
symbolic or numeric result, 9

D

defining procedures, 28
definition

creating, 10
Digits

for numerical evaluation, 12

E

editing, 6
editing units, 12
entering
math container, 6, 9
text container, 6, 14
entering math
basics, 10
command completion, 10
complex numbers, 11
definition, 10
in a text paragraph, 14
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nonexecuting, 13, 14
using palettes, 10
entering units, 11
evalf, 9
evaluation
disable temporarily, 13
order of, 13
using =, 9
evaluation modes
numeric and symbolic, 9

F
flip
to front/back, 7
format
section style, 16, 17
using style sets, 15
functions
Maple, 27

G
graphing, 27
grid, 6

H

help
on additional Maple commands, 3
help system, 3
hide commands, 18
Home page, 1
hyperlinks
inserting, 25

|

i, 11

images
drawing on, 18
inserting, 18

insert
header or footer, 29
section, 16

K

keyboard shortcuts, 32

L
linking

to another worksheet, 25
location

grid cursor, 6



Index

Maple Flow
versus Maple, 2
Maple Flow window, 4
math container
set background color, 14
moving
math container, 6
changes evaluation order, 13
text container, 6

N

numeric evaluation, 9
numeric formatting options, 10

)

Options
default zoom, 4
specify decimal places, 10

P

packages
using Maple, 27
palettes, 4, 10

units, 11
PDF

export to, 31
Pi, 9

plotting, 27
printing, 29
programming, 28

R

rounding
specify decimal places, 10

S

scientific formatting, 10
section

expand or collapse, 16
sections, 16

display of, 17
shortcuts

inserting, 25
symbolic evaluation, 9

T

text

formatting, 14

formatting using built-in styles, 15
text container, 14

entering math in, 14
toolbars, 4
turning evaluation off, 13
tutorials, 1

U

units, 11
rescaling, 12

view
print extents, 29
visual indicators, 18

y4

Zoom
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