User Interface - Maple Help

Online Help

All Products    Maple    MapleSim


Maple 10 Graphical User Interface (GUI) Updates

  

With Maple you can create powerful interactive documents for use as business or education tools.  Many features have been added or augmented in the Maple 10 Standard Worksheet interface.

  

The following example was created in Worksheet mode using Document blocks.

  

This page provides an overview of the following new and updated GUI features.

• 

Document and Worksheet Modes

• 

2-D Math

• 

Palettes

• 

Symbol Recognition Palette

• 

Embedded Components

• 

Interactive ImportData Interface

• 

Tables

• 

Document Blocks

• 

Task Templates

• 

Autoexecute

• 

Maplet Builder

• 

Equation Manipulator

• 

Installer Builder

• 

Interactive Data Analysis

• 

Maple T.A. Authoring Environment

• 

Bookmarks

• 

Help System

• 

New Manuals Available Online

• 

Quick Reference

• 

New User Tour

• 

Maple Resources

• 

New User Roadmap

• 

Manage Style Sets

• 

Hyperlinks

• 

Maintaining Help Database Files

• 

Sketch Regions

• 

Window or Tabbed Pane

• 

Command-Symbol Completions

• 

Equation Labeling

 

Document and Worksheet Modes

2-D Math

Palettes

Symbol Recognition Palette

Embedded Components

Interactive ImportData Interface

Tables

Document Blocks

Task Templates

Autoexecute

Display Hidden Formatting Attributes of a Worksheet

Maplet Builder

Equation Manipulator

Installer Builder

Interactive Data Analysis

Maple T.A. Authoring Environment

Bookmarks

Help System

New Manuals Available Online

Quick Help

Quick Reference

New User Tour

Maple Resources List

New User Roadmap

Manage Style Sets

Hyperlinks

Maintaining Help Database Files

Units

Sketch Regions

Window or Tabbed Pane

Command-Symbol Completion

Equation Labeling

Document and Worksheet Modes

  

Document mode provides a blank sheet for solving problems immediately in standard math.  No Maple commands are required and no input prompt regions are displayed.

  

To start in Document mode:

• 

From the File menu, select New, and then Document Mode.

  

For details, see worksheet/documenting/DocumentMode.

  

Worksheet mode provides a worksheet with a Maple prompt. You can insert input regions with standard math (2-D Math default) or Maple Input, text regions, and Document blocks.

  

To start in Worksheet mode:

• 

From the File menu, select New, and then Worksheet Mode.

2-D Math

  

2-D Math input is the default setting for Maple Worksheets and Documents. It is executable standard math displayed in a format similar to that found in business and education documents and tools.

  

Compare 2-D Math and Maple Input (1-D Math) in Worksheet mode:

  

2-D Math in Document mode:

• 

With 2-D Math, you do not require a semicolon to terminate the command and expression.

• 

In Worksheet mode, all 2-D Math input can be executed and displayed by pressing the ENTER key.

• 

In Document mode and in Document blocks, all 2-D Math input can be executed by using the Evaluate (ENTER) or Evaluate and Display (Ctrl=) context-menu options. For details, see 2-D Math.

• 

You can insert Maple Input and 2-D Math by using the Insert menu or by using the F5 key to switch between input modes.

• 

You can apply session or global display settings related to 1-D and 2-Math modes in the Options Dialog.

  

From the Tools menu, select Options. In the Options dialog, click the Display tab. Select the appropriate mode from the Input and Output display drop-down lists.

• 

In addition to using palettes for 2-D Math input, shortcut keys are available. See 2-D Math Shortcut Keys and Hints.

• 

The Type Setting Rule Assistant is graphical user interface for changing the current Typesetting rules. These rules control the input and typesetting of 2-D Math within the Standard Worksheet interface. For more information, see worksheet/expressions/TypesettingRuleAssist.

Palettes

• 

A palette is a collection of buttons representing items, such as predefined symbols, expressions, operators, and Matrices. By clicking the buttons on the palettes, you can build or edit mathematical expressions without having to remember the Maple command syntax. Maple provides over 20 palettes: 7 Expression, 11 Mathematical, and 8 Alphabetical.

  

For details, see Palettes.

Symbol Recognition Palette

• 

With over 20 palettes and 800 symbols, sometimes finding the right symbol to insert can be time consuming. The Symbol Recognition palette provides an efficient way to find and insert the right symbol. You draw the symbol with your mouse and then Maple matches your input against symbols available in the system.

  

For details, see Palettes.

Embedded Components

• 

You can embed simple graphical interface components, for example, a button, into your worksheet. These components can then be associated with actions that are to be executed. For example, the value of a slider component can be set to a worksheet variable, or a text field can be part of an input equation.

  

 

  

 

  

 

• 

The graphical interface components are inserted by using the Components palette. For details, see the Palettes and EmbeddedComponents help pages.

Interactive ImportData Interface

• 

A new interactive interface has been added for importing data from external sources into Maple, which currently supports various source formats including image and audio files as well as many data sources, such as MatrixMarket, MATLAB®, and Delimited data.

  

For details, see Import Data.

Tables

• 

Maple 10 allows you to insert tables in the Standard Worksheet interface. Tables provide a convenient mechanism for organizing content.

  

From the Insert menu, select Table and specify the number of rows and columns in the table creation dialog. The default properties for the table include visible borders and auto-adjustment to 100% of the document width.

• 

Content that can be placed in a section can also be placed into a table cell including other sections and tables. Table cells can contain a mix of input commands, 2-D Math, plots, and images.

• 

You can control the visibility of cell borders and contents, table size and cell alignment, execution order of cell contents, and more.

  

For details, see worksheet/documenting/table.

Document Blocks

  

 

• 

Document blocks can be created in Worksheet mode to enhance content formatting. Document blocks are also the basis of Maple Documents.

• 

With the Format>Create Document Block feature, you can create worksheets with better presentation flow. Text and 2-D Math output can be displayed in the same line, and extensive Maple procedures can be hidden, revealing only associated text and final results.

  

For details, see worksheet/documenting/documentblocks.

Task Templates

  

A task template is a section of worksheet content that helps you perform a specific task, such as:

• 

Performing a mathematical computation, for example, solving an equation symbolically or numerically, or determining the Taylor approximation of a function of one variable

• 

Constructing a Maple object, for example, a function

• 

Creating a mathematical document, for example, an application

  

Over 100 task templates are available in Maple 10.

• 

The tasks are organized in the help system by subject, to help you quickly find the appropriate task. (Tools>Tasks>Browse)

• 

Each task is a collection of Maple worksheet content, such as 2-D Math, commands, and plots that you can directly insert into your worksheet. You need only specify the parameters of your problem, and then run.

• 

You can also create custom tasks.

  

For details, see Maple Tasks.

Autoexecute

  

Execution groups are the fundamental computation and documentation elements of worksheets. If you place the cursor in an input command and press the ENTER or RETURN key, Maple executes all of the input commands in the current execution group.

  

In Maple 10, the Autoexecute feature allows you to designate regions of worksheet for automatic execution.

Setting the Autoexecution Feature

1. 

Select the region that must be automatically executed when the worksheet o pens.

2. 

From the Format menu, select Autoexecute, and then Set.

  

For details, see Setting the Autoexecution Feature.

Display Hidden Formatting Attributes of a Worksheet

• 

You can display icons that indicate the presence of hidden formatting attributes in the worksheet, such as document block boundaries, execution groups marked for autoexecution, and bookmarks.

  

From the View menu, select Markers. A vertical bar is displayed along the left pane of the worksheet. Icons for hidden elements are displayed in the vertical bar next to the associated content in the worksheet.

  

For details, see worksheet/reference/markers.

Maplet Builder

  

The Maplet Builder is a graphical interface to the Maplets package. Using the Maplet Builder, you can define the layout of a Maplet, drag and drop elements (visual and functional components of Maplets), set actions associated with elements, and directly run a Maplet. The Maplet Builder is available only in the Standard Worksheet interface.

  

Note: A Maplet is a graphical user interface containing windows, textbox regions, and other visual interfaces, which gives a user point-and-click access to the power of Maple. For more information, see Overview of Maplets.

  

To access the Maplet Builder:

• 

From the Tools menu, select Assistants, and then Maplet Builder.

Equation Manipulator

  

The Equation Manipulator is a graphical interface that allows you to perform standard operations on an equation without knowing the syntax of Maple commands.  It is available in the context menu for an equation.  For more information, see Using the Equation Manipulator.

Installer Builder

  

The Installer Builder is a graphical interface to the InstallerBuilder package in which you can create installers for your Maple Toolboxes. Toolbox installers are executable Maple archives, .mla files. For details, see InstallerBuilder.

  

For information about toolboxes, go to the Maple Web site, http://www.maplesoft.com/products/toolboxes.

  

To access the Installer Builder:

• 

From the Tools menu, select Assistants, and then Installer Builder.

Interactive Data Analysis

  

The InteractiveDataAnalysis Assistant is a graphical interface to the data analysis routines in the Statistics package.

  

You can display textual and graphical information about data sets, traverse data sets, and generate new data sets via standard operations on existing ones.

  

To access the Interactive Data Analysis Assistant:

• 

From the Tools menu, select Assistants, and then Data Analysis.

  

For details, see the Statistics/InteractiveDataAnalysis help page.

Maple T.A. Authoring Environment

  

You can author a subset of Maple T.A. questions and assignments using the Maple worksheet interface. Using the authoring environment, you can create Maple-Graded, Multiple Choice, True-False, Fill-in-the-Blanks, and Essay type questions. You can then test these questions in Maple before loading them to Maple T.A. For details about the Maple T.A. authoring envirnoment, see the help page. For details about the Maple T.A. product, go to Maple T.A.

Bookmarks

• 

Previously, bookmarks were inserted by using the Edit menu. In Maple 10, the Bookmarks option in the Format menu allows for the creation, modification, and deletion of all bookmarks.

• 

Additionally, using the View>Marker feature, hidden attributes such as bookmarks are now visible.

  

For details, see worksheet/documenting/bookmarks.

Help System

  

The Help Navigator has been expanded. You can search all or specific Resources such as Help Pages, Tasks, definitions in the Maple and Engineering dictionary, Tutorials, and Manuals.

  

Search results are displayed as a list in the Search Results tab of the left pane.

• 

Topic searches reveal a list of matching topics sorted by exactness of match.

• 

Text searches reveal a list of topics based on keyword frequency.

Help System Icons

  

Icons are used to distinguish Resources in the help system.

  

 

  

Question mark indicates a help page.

  

 

  

WS indicates an example worksheet. Example worksheets open in a new window.

  

 

  

D indicates a Math Dictionary term.

  

 

  

T indicates a Task template.

  

 

  

M indicates a manual.

• 

A folder icon in the Table of Contents tab indicates that a topic can be expanded into subtopics.

Open Help Page as Worksheet

  

In help pages, examples are not executable. The Maple help system allows you to open help pages as worksheets that you can execute.

• 

Ensure that the help page is displayed in the right pane of the Help Navigator. From the View menu, select Open Page as Worksheet. A new worksheet window opens.

• 

Alternatively, click the Open as Worksheet icon.

Multiple Help Navigators

  

By default, only one Help Navigator opens per session. To allow more than one help navigator open in a session, select the Multiple Help Navigators check box in the Options Dialog.

New Manuals Available Online

  

The Maple Getting Started Guide and the Maple User Manual (previously, the Learning Guide) have been rewritten. They are available online through the Help menu.

Getting Started Guide

  

The Getting Started Guide provides an introduction to the following Maple features.

• 

Worksheets and powerful interactive documents

• 

The help system

• 

Point-and-click interaction with various interfaces to help you solve problems quickly

• 

Maple commands and standard math notation

• 

A road map for solving problems

User Manual

  

The User Manual provides an overview of the Maple product including:

• 

Document mode

• 

Worksheet mode

• 

Performing computations

• 

Mathematical computations

• 

Plots and animations

• 

Creating mathematical documents

• 

Maple expressions

• 

Basic programming

• 

Using and creating custom Maplet(TM) applications

• 

File input and output, including using Maple with third party products

Accessing Manuals Online

1. 

From the Help menu, select Manuals, Dictionary, and more.

2. 

Select Manuals and then Getting Started Guide or User Manual.

  

The manuals open with the Table of Contents displayed.

Quick Help

  

Every time you open a Document, Maple displays a Quick Help pop-up list of important shortcut keys. To invoke Quick Help any time, press F1. To learn more about items listed in the Quick Help pop-up list, see Quick Help Details.

Quick Reference

  

The Maple Quick Reference Card provides information on how to access commonly used commands, tools, interfaces, and more.

• 

Topics include Document mode versus Worksheet mode, common operations, 2-D Math editing operations and keyboard shortcuts, plotting and animation, mathematical operations, important Maple syntax, expressions versus functions, units and tolerances, input and output, and interactive tools and utilities.

Accessing the Quick Reference Card

• 

From the Help menu, select Quick Reference.

New User Tour

  

The New User Tour has been rewritten and redesigned. Topics include:

• 

Ten Minute Tour

• 

Numeric and Symbolic Computations

• 

Matrix Computations

• 

Differential Equations

• 

Special Functions

• 

Optimization

• 

Statistics

• 

Programming and Code Generation

• 

Dictionary of Math and Engineering

• 

Units and Tolerances

• 

Education, Assessment, Maple T.A.

• 

OpenMaple

• 

Maplet and MapleNet

Accessing the New User Tour

• 

From the Help menu, select Take a Tour of Maple.

Maple Resources List

  

Your work in Maple is supported by many resources. The Maple Resources page provides an image and description of various tools, information sources, menu types, and Web sites, along with access information.

• 

From the Help menu, select Manuals, Dictionary, and more, and then Maple Resources.

New User Roadmap

  

For new users, a roadmap to solving problems or learning about Maple is provided.

• 

From the Help menu, select Manuals, Dictionary, and more, and then New User Roadmap.

Manage Style Sets

• 

You can use the paragraph and character style set of a particular worksheet as the default style for all worksheets.  Previously, style set management was accessed from the main Style Management dialog. This feature now has a separate dialog.

  

From the Format menu, select Manage Style Sets. The Style Set Management dialog opens.

  

For details, see the Overview of Maple Paragraph and Character Styles and Style Sets help page.

Hyperlinks

• 

You now have the option of using an image as a hyperlink in your worksheet. In .mw files the image appears as a link. In .mws files, the link text you provide appears as the hyperlink.

• 

You can use hyperlinks in your worksheet to access information in a dictionary topic, help topic, Web page URL, and worksheet. You can also use hyperlinks to send an email or launch a Maplet application.

  

For details, see hyperlinks.

Maintaining Help Database Files

  

The menu items for adding and removing help pages from a help database (HDB) file have moved to the Tools>Help Database menu.

Units

  

The standard default context menus have been augmented with entries to assist in handling expressions containing Units. Submenu entries have been added to allow simplification, removal, conversion, and introduction of units into an expression.

  

Also, two palettes have been added that allow you to insert a unit from the SI system, the FPS system, or any general unit.

Sketch Regions

  

The Sketch feature has been updated. You can modify the sketch pad appearance by accessing the Canvas Style dialog.

  

With your cursor positioned in an inserted sketch pad, select the Sketch menu, and then Canvas Style. You can change background and grid color and set grid spacing.

  

For details, see Canvas Style of Sketch Pad.

Window or Tabbed Pane

  

Depending on the settings in the Options dialog, new worksheets or documents can open in a new window or tabbed pane. For details, see the Interface section in the Options Dialog help page.

Command-Symbol Completion

  

To list all Maple packages, commands, functions, or symbols that match entered text, select Tools>Command Complete or use the following shortcut keys.

  

Command + Shift + Space, Macintosh

  

Ctrl + Space, Windows

  

Ctrl + Shift + Space, UNIX

  

For more information, see 2-D Math Shortcut Keys and Hints.

Equation Labeling

  

Equation labeling allows you to reference Maple input and output in math areas of your worksheet. The label is associated with the last output within an execution group and with the all of the input group.

  

 

  

 

  

For details, see worksheet/expressions/equationlabels.

See Also

Index of New Maple 10 Features

trademarks