Restore Backup - Maple Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : Getting Started : Menus : Document Menu Bar : File Menu : Recent Documents : worksheet/managing/restorebackup

Restore Backup

The File menu displays a list recently opened documents. This may include files from a previous session.

You can restore a backed up document.

By default, backups of open files are automatically saved. See more information below.

  

To restore backups:

• 

From the File menu, select Recent Documents, then Restore Backup. All backed up files are opened.

Auto Save

By default, the auto save feature automatically saves all open worksheets.

Auto save saves a copy of the worksheet. The filename is the worksheet's filename with _MAS appended to it. When the worksheet is manually saved, the _MAS file is deleted.

When you open a _MAS worksheet that has been automatically saved, the worksheet is read-only. Therefore, you must use Save As to save the _MAS worksheet as a Maple worksheet.

Auto save does not save the worksheet under the following conditions:

• 

The worksheet does not have a filename associated with it.

• 

The worksheet has not been changed.

• 

The worksheet was loaded using the HTTP protocol.

Auto Save Options

You can control the Auto Save feature through the Options Dialog.

– 

Control whether Auto Save is enabled.

– 

Control the frequency for saving worksheets.

– 

Control whether auto save files are kept or deleted when Maple is shut down normally.

For details, see Options>General.

Auto Save File Location

For files that have not yet been saved by the user, the auto save files are saved in a subdirectory of your home directory. For example,

• 

On Windows, C:\Users\userid\maple\backup, where userid is your user ID.

• 

On Mac, $HOME/maple/backup

• 

On Linux, $HOME/maple/backup

For files that were previously saved by the user, the auto save files are saved in a maple/backup subdirectory of the location where the file itself resides.

See Also

List of Recently Opened Documents

Open a Worksheet

Options>General

Save a Worksheet

Save As